查看: 4832|回复: 9

【转帖】关于 STK 9 版本发布的重要声明

[复制链接]
发表于 2009-12-28 00:36:53 | 显示全部楼层 |阅读模式

登录后才可以下载和分享资料

您需要 登录 才可以下载或查看,没有帐号?注册

x
关于 STK 9 版本发布的重要声明
晴空(翻译)
AGI 产品现在支持 Windows Vista 操作系统
所有发布的 AGI 9 产品现在均支持 Windows Vista。列表提供了所有已知和已修正的问题。
不再支持的产品

STK/Space Environment
STK 8 是提供和支持 STK/Space Environment 产品的最后一个版本了。新替换版本
已经作为 STK 9.0 的子集发布。

STK/PODS
STK 8.1.3 是提供和支持 STK/PODS 产品的最后一个版本了。目前的 STK/PODS 客
户可以享受折扣价格升级到 ODTK。

STK/DIS
DSim 发布后,STK/DIS 已经从 STK/Integration 删除。
不再支持 Windows 2000 操作系统
STK 9 现在无法运行在 Windows 2000 操作系统上。
用户必须要升级到 Windows XP、
Windows XP Professional x64 或者 Windows Vista。
不再支持 Visual Studio 2003
正式支持的是 Visual Studio 2005 和 2008。
不再支持 Visual Basic 6
从 STK 9 开始,不再支持用 VB6 创建定制的 STK 引擎应用程序。
STK Java API JDK 最低的兼容版本改变
STK 的 Java API 的最低兼容版本将在 STK 9.0 后的下个发布版本改变,这是因为
Sun Microsystems 对 JDK 1.4.2 不再支持,具体见如下网址:
http://java.sun.com/j2se/1.4.2/download.html.目前STK Java API最低的兼容版本 为JDK
1.4.2_10。
支持的 MATLAB 的版本
STK 9 支持 MATLAB R2006b 以及之后的版本。
AGI World Terrain(世界地形)和 AGI High Resolution
Maps(高分辨率地图)
AGI 世界地形和 AGI 高分辨率地图可以在 AGI 的数据光盘中得到。
安装改变
STK Java API 不再需要分开安装。它被纳入到 STK 和 STK 引擎安装中。
STK/Analyzer 现在是单独的安装光盘或者从 agi.com 网站下载。
安装目录 STKData\Scripting\Init 现在添加到 PERL5LIB 环境变量中,使得在 STK
使用 perl 更为方便。
如下的 STK 引擎的初级组件现在包含在
<STK9_Installation_Path>\bin\STKPlugins.xml 文件中,当 AgPluginReg.exe 运行时,
文件将自动被注册。
<STK9_Installation_Path>\bin\Primary Interop Assemblies\AGI.STKUtils.Interop.dll
<STK9_Installation_Path>\bin\Primary Interop Assemblies\AGI.STKObjects.Astrogator.Interop.dll
<STK9_Installation_Path>\bin\Primary Interop Assemblies\AGI.STKObjects.Interop.dll
<STK9_Installation_Path>\bin\Primary Interop Assemblies\AGI.STKX.Interop.dll
<STK9_Installation_Path>\bin\Primary Interop Assemblies\AxAGI.STKX.Interop.dll
STK 运行程序现在支持大地址访问
包含在这次发布中的 STK 的运行程序和其他应用、转换程序现在支持大地址访问。
因此,这些应用程序将能支持:
2 GB 的 RAM,在 32 位平台上,通用引导选项
3 GB 的 RAM,在 32 位平台上,合适的引导选项
4 GB 的 RAM,64 位平台
注册
AGI 产品现在使用 FlexNet 11.4.1 版本。该 FlexNet 版本是 Windows Vista 兼容的。
STK/Aircraft Mission Modeler 飞行任务建模器)

现在是单独注册的、
专用分析模块。
DSim 和 RTI 兼容性
DSim 9.0 需要一个兼容的支持 HLA 1.3 和 HLA 1516 标准的 RTI(运行支撑系统)

对于任一种标准,RTI 必须为 32 位的,支持 MSVC++7.1 或 MSVC++8.0 运行库。
HLA 1.3 是跟任何遵从 DMSO 标准的 1.3 RTI 相兼容,
HLA 1516 与 Mak Rti 相兼容。
如果你不知道你的 RTI 是否兼容,或者想为一个特定的 RTI 添加兼容性,请跟 AGI 的
技术支持联系。
在 DSim 9.0.1 发布时将提供 MSVC++9.0 运行库。


系统需求
系统
最小需求
建议配置
CPU
1 GHz
2+ GHz
内存
1 GB
2 GB
Windows XP/XP Professional
操作系统
Windows XP/XP Professional x64/Vista
x64/Vista
浏览器
Internet Explorer 5.5
Internet Explorer 7.0
3D 可视化需求
高端 OpenGL 兼容图卡(512+ MB 内
显卡
OpenGL-兼容卡(128 MB 内存)
存)
OpenGL
1.2
2.0+
Version
硬盘空间
1.5 GB
1.5 GB
回复

使用道具 举报

 楼主| 发表于 2009-12-28 20:28:40 | 显示全部楼层
再仔细看了晴空翻译的这个声明,补充说明几点:
1. STK/Space Environment 现在的名字是SEET,这点声明没有提及
2. analyzer只能从agi申请,是不能从网站下载的,这点声明说法欠妥
3. 分布式仿真支持Dsim很麻烦,不过国内用户很少这么用的,所以不用想这个问题
回复 支持 反对

使用道具 举报

发表于 2010-4-5 00:30:28 | 显示全部楼层
哪儿可以下载啊?
回复 支持 反对

使用道具 举报

发表于 2010-4-6 23:14:56 | 显示全部楼层
哪儿可以下载啊?
回复 支持 反对

使用道具 举报

发表于 2010-4-8 12:26:38 | 显示全部楼层
谢谢你的说明!
回复 支持 反对

使用道具 举报

发表于 2011-1-6 16:48:22 | 显示全部楼层
学起来不容易
回复 支持 反对

使用道具 举报

发表于 2011-10-14 20:05:58 | 显示全部楼层
需要STK的请发邮件至:stk_simulation@163.com
回复 支持 反对

使用道具 举报

发表于 2011-10-22 15:57:04 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-1-31 03:28:52 | 显示全部楼层
可以脱离环境运行二次开发的程序吗?怎么设置
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表